Erro #valor! em fórmula do Excel que deveria ficar vazia

SE(E(C20;D20)="";"";SE(B20>C20;C20+1-B20;C20-B20)-D20)
Eu ñ consegui entender pq essa fórmula só funciona quando tem valor nas células onde eu disse pra ele q se estiverem vazias é pra resultar vazio.
Alguém sabe me ajudar nessa questão?

Oi Fesson, bom dia! :slight_smile:

image

image

Não entendi porque na sua fórmula, você dentro do E colocou o D20.
Eu interpretei aqui como o D20 sendo o resultado da B20 e C20.
Logo, você não precisa dizer que o D20 = “”… só o C20 já basta, porque se um está vazio, o outro vai estar por consequência, pois o D20 é onde a fórmula está sendo escrita.

Eu adaptei a fórmula aqui, ai posso tirar o E, porque vai ser só um parâmetro (C20) e ficou assim: =SE(C20="";"";SE(B20>C20;C20+1-B20;C20-B20))
Removi também aquele -D20 do final do 2º SE, porque não faz sentido, porque já resolvemos a questão de aparecer valor ou não na D20 no 1º SE.

Então, se C20 for vazio, o resultado de D20 vai ser vazio também.
Se C20 tiver algum conteúdo, então vamos usar o 2º SE para cálcular as horas.

Teste aí!

Abraço

2 curtidas

Boa noite!
A função e() retorna VERDADEIRO ou FALSO, logo E(C20;D20) nunca vai ser igual a “”(vazio), tente fazer E(C20="";D20="")=VERDADEIRO

1 curtida

Este tópico foi fechado automaticamente 14 dias depois da úlima resposta. Novas respostas não são mais permitidas.